Can not run example


I have python, python3 and netgen installed on my ubuntu system. Under the “wetting the apetite” section of the tutorials I have downloaded the python code for Navier STokes equations But when I run it either with python, python3 or netgen, I get the error says

[quote] File “”, line 28, in
NameError: name ‘dx’ is not defined[/quote]

Same happens with the easiest code, I can not run it either because of the same error. Do i need to install something else/new?

Thanks in advance.

Hi Mr./Mrs. noname,

Are you using an older version of Netgen/NGSolve? The dx symbol is only introduced around June/July 2019. If you use one of the recent stable versions it should however be available. Simply check for an update.


Thanks Christoph… I did an update and restarted my system. Now I get

netgen: error while loading shared libraries: cannot open shared object file: No such file or directory

Error. Do you have any prior experience with this?Simply doing sudo ldconfig does not solve my problem
I did ldconfig -p | grep libTKBRep and it seems it is not installed in my system


The Ubuntu-NGSolve package depends on liboce-ocaf-dev, which provides Check if this package is installed on your system.



I have seen other users had similar experience in this link

Following the solution steps explained there solved my issue.

Thanks again.