Error in mesh generation when build from sources

I’m using Netgen to mesh stp (attached).

The file is converted successfully when install Netgen using the installer but failed with errors when build Netgen from sources, what am I missing?

The generated messages in both cases are attached.

I’m using latest installer and latest code.
Windows 10
Tried with Python 3.7 & 3.8 & 3.9

Thanks in advance.

Attachment: as1-oc-214_2020-11-19.stp

Attachment: install.txt

Attachment: src.txt

I’m building from source and it works for me. What version of occ do you use? What git commit are you building from when building from source?


Thanks for your reply.

For occ, I’m using USE_OCC option in CMake to install occ with Netgen.
A picture for occ version is attached.

For the git commit, I tried once with the latest on master and tried another time with v6.2.2009 tag.

Your help is appreciated.

Hm. OCE 0.18.1 is based on OCCT 6.9, could you try using a newer version (7.5 is currently available) and try it again? I think this might be a bug in occ that is already fixed in newer versions. The installer is built with occ 7.4.


I tried with occ 7.5 and it worked, many thanks.