Installation via PIP/rep in ubuntu

Dear all, first of all I want to apologize for the double-posting but the forum neither let’s me edit nor delete my old post.
Now to my problem. Hey there, I wanted to use NGSolve after some time for some simulations regarding Lange Nacht der Forschung (soon). Therefore I installed it, system is Ubuntu 20.04
I first used the ubuntu installer, I want to mention, that it showed me the following when I tried to add the rep

Within the installation, the following occured

[quote]Entpacken von ngsolve (6.2.2201-0~ubuntu20.04.1) …
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/ngsolve_6.2.2201-0~ubuntu20.04.1_amd64.deb (–unpack):
Versuch, »/usr/bin/netgen« zu überschreiben, welches auch in Paket netgen 6.2.1804+dfsg1-3build2 ist
dpkg-deb: Fehler: »einfügen«-Unterprozess wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Fehler traten auf beim Bearbeiten von:
E: Sub-process /usr/bin/dpkg returned an error code (1)[/quote]

SOOO I was like “that’s not good” and tried the installation via pip (which is installed)

quote michael@michael-ThinkPad-X1-Carbon-5th:~$ pip install ngsolve
ERROR: Could not find a version that satisfies the requirement ngsolve (from versions: none)
ERROR: No matching distribution found for ngsolve[/quote]

So no NGSOLVE for me. Anyone any clue what is wrong?


sorry for the forum troubles, we are working on it.

Concerning your issues:
PPA: Seems you have an old version of netgen installed (not maintained by us). Remove that one and try to reinstall ngsolve (the ngsolve package also contains netgen, that’s why you get the conflict error).

PIP: what’s your output of
pip --version
pip - Packages are only available for python 3.8 to 3.10. Possibly “pip” is referring to python2, in this case you can try “pip3 install ngsolve”


PS: In any case, make sure you have only one version of netgen/ngsolve installed globally (i.e. delete hat old netgen package, also when using pip)

Dear Matthias, thank you for your answer. Your guess with pip was correct, at least almost
However, it seems 3.7 is the current supported version for pip

quote michael@michael-ThinkPad-X1-Carbon-5th:~ pip --version pip 20.0.2 from /home/michael/anaconda3/lib/python3.7/site-packages/pip (python 3.7) (base) michael@michael-ThinkPad-X1-Carbon-5th:~
(base) michael@michael-ThinkPad-X1-Carbon-5th:~$ sudo apt-get install python3-pip
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
python3-pip ist schon die neueste Version (20.0.2-5ubuntu1.6).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 14 nicht aktualisiert.[/quote]
So, I than tried the rep and did a remove first

It removed one packate, however it still aborts the installations
Thanks and greetings from Uni Wien