Issue with meshing

Hello everyone:

I am new to the forum and also a brand new user of Netgen. Sorry that my question does not relate to python programming but I could not find other places to post it.

I have to do a FE-Analysis for a hook spring for my master thesis. I use the FreeCAD and notice that Netgen is included in the software as one of the meshers. I have already tried to mesh the geometry of the spring with Netgen in FreeCAD and everything goes well, the mesh is done in no more than 5 seconds and the FE-Analysis also works without any error reports.

Then I think about meshing the spring in Netgen externally since that is also recommended by FreeCAD if a feiner Mesh is required. But then I have got problems. The Mesh always goes slower and slower and the vantilation fan of my laptop begins to rotate madly, which means the CPU is overloaded, so I can not let it mesh anymore or the laptop could be broken… I have noticed that the part of the elements between two coils are glued together, although there is still space between the coils…

It is a bit strange for me since the key-setups for the mesh like the max. and min. size in FreeCAD and Netgen are the same, but they produced totally different results with the same mesher. I have tried to heal the geometry before the mesh and play a little bit with the element size, but it did not help. It would be grateful if someone could give me some tips on dealing with the issue, or tell me where I could find the anwser of it.

Thanks a lot:) and

Can you attach the step file? Also attaching images should work now. Are the boundaries sewed together?

Hallo! Thanks for the anwser. Sorry about it that I did not notice that the pictures were not uploaded. The pictures and the stp data are now attached.

I am sorry, but I am not sure if the files are really attached, because on my PC it shows something like “you do not have permissions to access this page”. I would like to ask that could it be downloaded on your side?