PIP installers available!

Thank you for your response!

I am not quite sure where I can find the pip installer. I see this comment few times but Im not sure where it is and if its a link to download directly?

Thank you so much for your help

As I wrote, just run
python3 -m pip install ngsolve
in the console.


Thank you for clarifying.

I entered this command in “terminal” window and this is the screen I got (I tried this twice just to doublecheck). see below:

But then when i open Netgen, this is the warnings I get. see images attached. Its the same message box. (all of this opens in “terminal” app immediately.
Let me know what else I can do


I am sorry for asking again. but when i removed the Netgen bundle and ran the command in “terminal” app on MacOS, it still show the popup screen as this: I am not sure what else to remove besides the Netgen application. I am sorry for being so clueless. thank you for any help:Defaulting to user installation because normal site-packages is not writeableRequirement already satisfied: ngsolve in ./Library/Python/3.9/lib/python/site-packages (6.2.2302)Requirement already satisfied: netgen-mesher==6.2.2302 in ./Library/Python/3.9/lib/python/site-packages (from ngsolve) (6.2.2302) [Process completed]

Try to run
python3 -m netgen
to start the version you installed with netgen (the warning you got with installation is no problem)


I did this and got this popup screen below. the thing is I removed the Netgen bundle so I dont have it on my mac anymore. should I redownload the Netgen? see below for the popup screen/Users/farahpiatek/Library/Python/3.9/lib/python/site-packages/netgen/main.py:1: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module’s documentation for alternative uses import imp, threading, sysDEPRECATION WARNING: The system version of Tk is deprecated and may be removed in a future release. Please don’t rely on it. Set TK_SILENCE_DEPRECATION=1 to suppress this warning. [Process completed]

Hello, I am experiencing a similar issue that was described previously with the DLL failures for libngpy. Attempting to run the netgen command in cmd or anaconda terminal with either Python 3.10 or 3.7, or running the first step under poisson.ipynb returns the same errorImportError: DLL load failed while importing libngpy: The specified module could not be found.
I have tried the previous solutions using the import os method to Jupyter notebook but the same error for libngpy is returned. I have also tried adding the directories directly to path, I am not sure what else to try.

Launching the netgen application directly works and opens the gui but I would prefer to work through Jupyter if possible.

I am using Windows 10

Any insight would be appreciated.

Thank you in advance,

I have the same problem as @paul.stocker. I tried to install ngsolve with pip on windows and when trying to import ngsolve, the following error pops up:
from .ngslib import version, ngstd, bla, la, fem, comp, solve
ImportError: DLL load failed while importing ngslib: The specified module could not be found.
Did anyone find a solution for this problem?

For anyone encountering the same issue:
I was finally able to resolve it! It was an package issue for me, as i work with anaconda.
After creating a new environment with conda and python 3.9, i used pip to install ngsolve ( and numpy,matplotlib,scikit-image) and everything worked fine. But when I started the python script I got the DLL Error as shown in the previous message.
When I checked the packages inside the environment with “conda list” I noticed that mkl, netgen-mesher and intel-openmp where missing. They were installed in the python39 file (c:\users.…\appdata\roaming\python\python39\site-packages) instead of the corresponding environment file (C:\ProgramData\anaconda3\envs\myenv\Lib\site-packages).
So i just uninstalled and re-installed mkl and netgen-mesher from inside the environment and checked the list again, where the missing packages now appeared. And then when running the script again, it worked!
I hope this helps someone.

PS: This is my working package list, if someone needs it:

Name Version Build Channel

ca-certificates 2023.01.10 haa95532_0
contourpy 1.0.7 pypi_0 pypi
cycler 0.11.0 pypi_0 pypi
fonttools 4.39.3 pypi_0 pypi
imageio 2.28.1 pypi_0 pypi
importlib-resources 5.12.0 pypi_0 pypi
intel-openmp 2022.2.1 pypi_0 pypi
kiwisolver 1.4.4 pypi_0 pypi
lazy-loader 0.2 pypi_0 pypi
matplotlib 3.7.1 pypi_0 pypi
mkl 2022.2.1 pypi_0 pypi
netgen-mesher 6.2.2302 pypi_0 pypi
networkx 3.1 pypi_0 pypi
ngsolve 6.2.2302 pypi_0 pypi
numpy 1.24.3 pypi_0 pypi
openssl 1.1.1t h2bbff1b_0
packaging 23.1 pypi_0 pypi
pillow 9.5.0 pypi_0 pypi
pip 23.0.1 py39haa95532_0
pyparsing 3.0.9 pypi_0 pypi
python 3.9.16 h6244533_2
python-dateutil 2.8.2 pypi_0 pypi
pywavelets 1.4.1 pypi_0 pypi
scikit-image 0.20.0 pypi_0 pypi
scipy 1.9.1 pypi_0 pypi
setuptools 66.0.0 py39haa95532_0
six 1.16.0 pypi_0 pypi
sqlite 3.41.2 h2bbff1b_0
tbb 2021.9.0 pypi_0 pypi
tifffile 2023.4.12 pypi_0 pypi
tzdata 2023c h04d1e81_0
vc 14.2 h21ff451_1
vs2015_runtime 14.27.29016 h5e58377_2
wheel 0.38.4 py39haa95532_0
zipp 3.15.0 pypi_0 pypi