This is my error installing

/home/emmanuel/ngsuite/ngsolve-src/include/…/comp/meshaccess.hpp:960:36: error: ‘const class netgen::Ngx_Mesh’ has no member named ‘GetParentSElement’; did you mean ‘GetElement’?
return ElementId(BND, mesh.GetParentSElement(ei.Nr()));
multigrid/CMakeFiles/ngmg.dir/build.make:62: recipe for target ‘multigrid/CMakeFiles/ngmg.dir/mgpre.cpp.o’ failed
make[5]: *** [multigrid/CMakeFiles/ngmg.dir/mgpre.cpp.o] Error 1
CMakeFiles/Makefile2:480: recipe for target ‘multigrid/CMakeFiles/ngmg.dir/all’ failed
make[4]: *** [multigrid/CMakeFiles/ngmg.dir/all] Error 2
Makefile:138: recipe for target ‘all’ failed
make[3]: *** [all] Error 2
CMakeFiles/ngsolve.dir/build.make:115: recipe for target ‘dependencies/Stamp/ngsolve/ngsolve-build’ failed
make[2]: *** [dependencies/Stamp/ngsolve/ngsolve-build] Error 2
CMakeFiles/Makefile2:211: recipe for target ‘CMakeFiles/ngsolve.dir/all’ failed
make[1]: *** [CMakeFiles/ngsolve.dir/all] Error 2
Makefile:149: recipe for target ‘all’ failed
make: *** [all] Error 2


are you compiling NGSolve the first time or did you update your code?

If you did an update, did you also update the submodules (Netgen and pybind11) using

git submodule update --recursive

If you are compiling the first time. How did you configure and which system are you using?

Best regards,

I installed with sudo apt-get install ngsolve on ubuntu 17.04, plus I had an error when testing the jupyter-files / unit-2.9-fourthorder / fourthorder.ipynb problem, giving the following error:
Traceback (most recent call last):
File “”, line 29, in
a + = SymbolicBFI (-hessenn (w) * jumpdn (v, vhat), element_boundary = True)
File “”, line 24, in hessenn
return InnerProduct (n, hesse (v) * n)
RuntimeError: T_MultVecVec: dimensions do not fit

That’s why I tried to install it with:
export BASEDIR = ~ / ngsuite
git clone GitHub - NGSolve/ngsolve: Netgen/NGSolve is a high performance multiphysics finite element software. It is widely used to analyze models from solid mechanics, fluid dynamics and electromagnetics. Due to its flexible Python interface new physical equations and solution algorithms can be implemented easily. ngsolve-src


we provide binaries for the latest ubuntu (now 18.10) and the LTS versions 16.04 and 18.04.
The version you downloaded is outdated (ngsolve-6.2.1712), since this was the last time we build binaries for ubuntu 17.04. ngsolve binaries on launchpad
The file ( you tried to run is newer than the version of ngsolve you installed and thus did not work properly.

If you want to use binaries, you would have to update your ubuntu. Otherwise compiling for ubuntu 17.04 should still work. What did you do after cloning the repository? Did you follow all the instructions?
One problem could be that ngsolve found the outdated netgen (installed with apt-get) and used it instead of compiling the own submodule. Try to uninstall the ngsolve package using apt-get, delete everything in your ngsolve-build folder and restart from the configuringstep.

Also check that you have the submodules properly configured.