Ubuntu Repository Update Error

I am running Netgen/NgSolve on KDE Neon 16.04 (Ubuntu 16.04 backend). The NgSolve repository showed some updates recently, but trying to install them through apt throws the following error:

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Running sudo apt install ngsolve throws the same error. It is also worth noting that the version of Netgen/NgSolve that I downloaded from this repository a few months ago is still functioning fine.

Nothing else on my system is misbehaving. This looks like an issue with the repository, so I just wanted to give a heads up to you guys!


Thank you for the report.

I don’t claim that our package is perfect, but this seems to be an issue of the package manager. I couldn’t reproduce the problem on a clean Ubuntu 16.04 virtual machine.
Something similar happened also with nginx, see the link below. Maybe you can sort it out by following the instructions in the answer below:


I solved this problem by removing netgen from /usr/bin folder and then reinstall the NGSolve using the official guide for Ubuntu here

To remove netgen, type this in your terminal: sudo rm -rf /usr/bin/netgen