Cannot import name 'solve' from 'ngsolve'

Hi, yesterday I had a working installation (via pip) of Netgen/NGSolve.

Today it stopped working complaining that it cannot import “solve” from “ngsolve” whenever I try to do an “import ngsolve”.

In [1]: import ngsolve

Caught exception:
arg(): could not convert default argument into a Python object (type not registered yet?). #define PYBIND11_DETAILED_ERROR_MESSAGES or compile in debug mode for more information.
ImportError                               Traceback (most recent call last)
Cell In[1], line 1
----> 1 import ngsolve

File ~/.local/share/virtualenvs/FSI_tests-46Er30x1/lib/python3.11/site-packages/ngsolve/
     33         _mkl_rt = os.path.abspath(_mkl.get_resource_filename('mkl','../../Library/bin/mkl_rt.2.dll'))
     34         ctypes.CDLL(_mkl_rt)
---> 36 from .ngslib import __version__, ngstd, bla, la, fem, comp, solve
     38 from netgen import Redraw
     40 from pyngcore import BitArray, TaskManager, SetNumThreads, PajeTrace

ImportError: cannot import name 'solve' from 'ngsolve' (/home/manuel/.local/share/virtualenvs/FSI_tests-46Er30x1/lib/python3.11/site-packages/ngsolve/

I tried reinstalling it to no avail.

My OS is Debian Bookworm and I’m using python 3.11.2. My Pipfile looks like this:

url = ""
verify_ssl = true
name = "pypi"

ngsolve = "*"
numpy = "*"
matplotlib = "*"

ipykernel = "*"
ipython = "*"

python_version = "3.11"

Any kind of help is really appreciated, thank you in advance!

Solved it by removing the old venv as well as __pycache__ and reinstalling it. Not sure where was the problem.