CPP Extension - CMake Error - SuiteSparse::umfpack not found


i just updated my NGSolve to the newest version. Unfortunately, now I cannot compile my CppExtension module. The CMake Error is:

CMake Error at C:/Program Files/ngsolve-v6.2.2002/cmake/NGSolveConfig.cmake:79 (add_library): Target "ngsextension" links to target "SuiteSparse::umfpack" but the target was not found. Perhaps a find_package() call is missing for an IMPORTED target, or an ALIAS target is missing?

Did I mess up something? Or was there a change regarding that?

Thanks in advance for your help!

Unfortunately, I still couldn’t find a fix for the issue. I’m using NGsolve 6.2.2003…

I ran into the same error using NGSolve 6.2.2004 when trying to build the current version of mylittlengsolve following the tutorial:

This should probably be addressed by the developers.

Using v6.2.1907 worked just fine.

Which version of CMake are you both running? Try to upgrade to the latest one. Note: cmake.org seems to be down currently, the installers are also available on github: Releases · Kitware/CMake · GitHub

I used CMake 3.16.x and updated today to CMake 3.17.2 but without success.



this issue seems to be the same as here:

I applied the mentioned workaround and issued a new nightly build:


Perfect! Thank you very much, now it works.