Failure to launch NetGen

I have Dell 5820 work station fully loaded. I take TurboCad drawings, save as STEP files. I use NetGen to create mesh, and use LISA to for stress and vibration analysis.
NETGEN hasn’t worked for some time. I uninstalled and reinstalled still, still says the same thing “Python35.dll does not exist”. Sure enough, searched whole C drive, no Python35.dll.
Is it to safe to take one of the several websites and download Python35.dll
It’s normally stored in C:/Windows/System32, but NETGEN may want it in the NETGEN folder, I don’t know.
Also, I don’t know whether to do 32 bit or 64 bit. My computer is 64 bit, but don’t know what NETGEN uses.
Any thoughts appreciated.

jeffwat here again. I found multiple versions of Python3.5 on and many newer versions. I installed the most recent NGSOLVE, and NETGEN still said said “python35.dll missing”, implying to me Netgen might not startup if I install the latest python.dll version. So unless I hear otherwise, I’m going to stick with pyton35.dll download.
I’ll let you know what appends

Did you use the latest installer from the homepage? Downloads
It should not use python 3.5, but a newer version. So your error suggests that you somewhere have an old version of netgen

Thank you for response. I did go to the home page, and did download on 5/28/2023.
So, looking at my installed program, it installed version 6.16164 versus latest I see as 6.2.2302.
I’m showing my age, but I used the original Netgen as a mesh generator/corrector when I tried to feed a STEP file into an inexpensive but quite acceptable LISA FE, and my STEP wouldn’t mesh in LISA. So, I’d then use NETGEN to create a mesh, which LISA could then use.
Since Netgen/NGSolve is now a complete FE program, I may not have permission to get the full software, and it just sent the older version - don’t have a clue.
In any event, I’ve got this old version, so maybe should just download the older python35.dll, and go with it. I first started using LISA, hence occasional NETGEN mesh creater in 2012.
I’ll do more research before I move ahead. Don’t have a clue otherwise why it downloaded and older version. Thanks again. Jeff