installing ngsolve on anacoda notebook and working on juoyter nootebook

Here are the instructions I followed to install it:
On anaconda prompt:
conda config --add channels conda-forge
conda config --add channels ngsolve
conda install ngsolve
then I followed instructions as mentioned in Using Jupyter notebook — NGS-Py 6.2.2302 documentation
an opened poisson.ipynb.
But it keeps showing ImportError : DLL load failed: The specified procedure could not be found.
Do I need to install poission.ipynb file in a specific location?

Please correct me if I am wrong somewhere or please provide step by step detailed procedure to download and make ngsolve work on Jupiter notebook. [attachment=undefined]c1.png[/attachment]
Thanks in advance.

With conda i’d suggest to use conda to install jupyter as well.

conda install jupyter

instead of the pip install.
Is it possible that you have another Python installation on your computer that is found instead of the anaconda one?

what is another python installation? I have only anaconda navigator installed in my system in which I use only jupyter notebooks to run python. There in no other python ide installed.
I tried with the command that you mentioned, but still the error persists. Any other way to make this work?

Can you try installing ngsolve in a dedicated environment?
Here is a guide on how to do this using anaconda navigator.
Maybe you have conflicting packages that could not be resolved in your base environment.

Thanks Sir.
It worked.
Now, the codes are getting executed without error but the draw(mesh) method is not displaying any plot or figures for any functions. Why it could be so?

Maybe you run the .ipynb file. If so, please try to convert it to a .py file, and run it.

Do you have a

import netgen.gui

statement at the beginning of the file? This opens the gui.

I want it to work on jupyter notebook

I was working with poisson.ipynb only.

Does the statement give you an error in the console?

@ankita: Currently, I don’t know how to show the image from Netgen GUI on Jupiter Notebook. I tried some ways, but it didn’t work.

no, it simply gets executed