Netgen crashes on some STEP files that worked OK in earlier versions.

When I try to mesh (or simply open) the attached file (.h extension added for forum), Netgen suddenly closes with no error messages. I also compiled Netgen with Open CASCADE Technology 7.3 and ran it through nglib.dll from my own application. It still crashes but with exit code 0xC0000374 (heap corruption?).

Several other files have the same problem and it’s intermittent, happening about 50-90% of the time, not every time. They were all working fine in Netgen 4.9 but fail in both 6.2.1808 and 6.2.1802.

Are any of the older versions such as 5.x more stable than 6?

I’m using Windows x64.

Attachment: ClevelandCityForge-3CLEVIS3-DEFAULT.STEP.h

We have also problems with some step files. We use the python interface to load a step file and then to generate a mesh. Sometimes, a step file works and sometimes the same step file does not work. Sometimes a very small modification of the underlaying geometry lead to a crash of the mesh generation (not sure this second problem is linked to the first one). I provide a sample STEP file. When you open this file using the netgen interface, the interface crashes with versions 6.2.1808 and 6.2.1809


Thanks for the extra example. It also goes differently each time I run it. Sometimes succeeds, sometimes crashes, and then with various different exit codes (0xC0000409 and 0xC0000005 but almost never the 0xC0000374 that I commonly get on my files). I also can’t get it to work on the older version either, so it might be a bigger problem that spans all versions but manifests itself differently.