NGSolve won't download

I went to your download page and followed the instructions for ubuntu and got the following:

I ran apt-add-repository “deb ‘lsb_release -sc’_‘dpkg --print-architecture’/”

Then ran apt-get update and got the following error:

Failed to fetch'lsb_release/InRelease Could not resolve ‘

I don’t find a /file/directory on your site. How do I download this.

Gary R

Hi Gary,

you have a typo in the command. It is
Just copy the commands from the downloads page and it should work.

Best regards,

Thanks for the reply but things still don’t work. I cut and pasted from the download page to the command line . The command string did place the proper line in my sources.list. But when i ran apt-get update I got the error "Err:22 zesty_amd64/ Packages
404 Not Found
Since I can’t find a directory under called files, I can only assume that there is something wrong with the URL.
Please help
Gary R.

Update: Tried command string with and and got the same results. The published command string has something wrong. I just doesn’t work!!!

Gary R.

Hi Gary,

This looks like connection problems like a proxy server or firewall.
Can you download the deb file directly?

If so, install it with

dpkg -i path_to_your_downloaded_deb_file apt-get -f install
as explained here:

Downloading the .deb file worked. Thanks. I’m still not sure why the other approach didn’t work. I’m not using a proxy server and have a firewall in a verizon supplied router. Haven’t had any problems before.

Thanks again for your help
Gary R.