No module named 'netgen' !

I had successfully installed the netgen. But, I am unable to import netgen from the jupyter notebook. I don’t know what I should be doing next to overcome this error.
Please netgen community help regarding this.
I am using Ubuntu 18.04.4. I had successfully implemented all steps regarding the installation. from 2020-05-02 00-14-15.png from 2020-05-02 00-17-22.png from 2020-05-02 00-17-48.png

Did you use the installer for netgen and conda for jupyter? Then your paths may not be set up correctly. Try using the conda installer for netgen+ngsolve as well then.

I tried with conda installer, but i am receiving an error ‘’';

Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.

Please tell me what i should do now ?

Here below i attached images that i countered during installation through conda. I am unable to install it. Please help regarding this… from 2020-05-03 10-22-24_part00.png from 2020-05-03 10-20-07_part01.png from 2020-05-03 10-20-46_part02.png from 2020-05-03 10-21-16_part03.png from 2020-05-03 10-21-55_part05.png

Hi have you tried installing it in a clean new virtual environment?

After you said i created new virtual environment

conda create -n ngsolve python=3.7

Now its working perfectly fine.

Thank you for your assistance.