Problem Netgen/NGSolve does not start, no error; any tips?

Dear Community,

i tried to (re)install Netgen/NGSolve on my Windows 10 PC as described in the Download section. Not the first time on this machine. Why the reinstall? Well, it stopped working, without any strange behaviour. I didn’t used the program for weeks and when i tried, it stopped at the following point:

Developed by Joachim Schoeberl at
2010-xxxx Vienna University of Technology
2006-2010 RWTH Aachen University
1996-2006 Johannes Kepler University Linz
Including OpenCascade geometry kernel
optfile ./ng.opt does not exist - using default values
togl-version : 2


This happens also after a new installation. I de- and reinstalled Python (3.7.9), Microsoft Visual Studio 2017 Redistributables. Tried different older versions (of Netgen/NGSolve) with the same outcome.
On a different W10-PC it worked (with the same installation files) like a charme.

Can you help me or give me a hint what i can try?

Hi Peter,

what does happen if you import ngsolve from python?

import ngsolve

Another try: In the command line, navigate to the netgen bin directory (the one containing netgen.exe) and try to run it from there.

It might be that netgen loads an incompatible version of a .dll and dies without any error message. We had troubles like this when another software provides tcl.dll and the path to the other .dll comes before the netgen directory in the PATH environment variable.


Hi Matthias,

thank you for your response!

this happens, when i import ngsolve:

[code]c:\Program Files\Python\Python37>python
Python 3.7.9 (tags/v3.7.9:13c94747c7, Aug 17 2020, 18:58:18) [MSC v.1900 64 bit (AMD64)] on win32
Type “help”, “copyright”, “credits” or “license” for more information.

import ngsolve
importing NGSolve-6.2.2104

so, no error message, but also nothing more.

starting netgen (with command line) at the bin directory leads to the same result described in the first post.

I compared the PATH enviroment variables for both W10-PCs. They seem to be the same, on the one with the problem there are a few more entries (Matlab, CMake, TDM-GCC, Miktex, Git).

Is there a way to find the incompatible dll or perhaps do you know another workaround?

Best, Peter

Miktex does ring a bell, maybe that’s the issue.

You can check the loaded dlls (and the symbols) with the dependency walker:
Just load the netgen.exe and see if you get any errors/red library names (don’t worry about the ms-api-… stuff, that’s usual).


Hi Matthias, hi all,

I haven’t it figured out yet. I removed Miktex and reinstalled netgen/ngsolve, but it stops at the same time.

dependency walker (as far as I can tell) gives no errors (except these EXT- and API-MS and a few false-positive) regarding ngsolve.


Guess guess i’ll try a few more combinations this weekend

Have you tried removing the path variables that are different? Does it work then? Then you can try adding them one by one and see which causes the problem…


Hi Peter,

It might be that nothing in dependency walker is red, but still wrong libs are loaded, are any dependencies pointing to matlab/miktex etc?

You may attach a screenshot or an exported report (not sure if that’s possible).


I compared the path variables, but adding one by one is what i want to try at the weekend :slight_smile:

I found the “profiling”-run (i am not familiar with this program, but this seems to provide more info) and attached the whole log-output (.txt).

does that tell anything? Thank you all for helping!

Attachment: dd34582abafcdd73c233cc938a575801

Found the problem!

After a week of testing and (re)installing different program versions I looked again at the dependencywalker-profile. A few lines made me suspicious, i deinstalled the graphic cards driver and netgen started again!

I installed the newest driver from amd (not from the lenovo-thinkpad-support-site) and not it works again. Thank you all!

Thank you Peter, you saved me a lot of time!