Hi guys,

I have a problem with the new VectorL2 FE space…

Attached you will find a simple SIP-DG method for a vector-valued Poisson problem.
Unfortunately, when I run the script with the VectorL2 space, I get the following error:
RuntimeError: undefined fespace ‘VectorL2’

When the VectorH1 space is used, everything works just fine.

What am I doing wrong?
Thank you for your help!



Hi Philipp,

I get the same error when using the VectorL2. I’ll have a closer look at the VectorL2 tomorrow.

You could also use a space with more components. This can be done with the “dim” argument.

V = L2(mesh, order=order,dim=mesh.dim, flags={"dgjumps":True})

Using your formulation it is still not working. When I switch to a formulation on the element boundaries, everything is fine. I’ll check if there is an issue with the skeleton BFI’s.

Attached is a file which should do what you want, using and L2 space with as many components as your mesh dimension and an element boundary formulation.



Thank you, Christoph, for your fast and helpful answer! :slight_smile:

Hi Philipp,

VectorL2 was actually not registered, I just fixed it. Your example is working now (with the next nightly build).


Thank you very much, Joachim.
The VectorL2 is very convenient :slight_smile:

Hi again,

is it possible that now somehow the dimensions of the div operator are not clean?
When I add the div-div term

a += SymbolicBFI( div(u)*div(v) )

I get:
RuntimeError: SymblicBFI needs scalar-valued CoefficientFunction

This does not happen with the VectorH1.


is fixed (and also the error handling)

Thank you, Joachim!