vtk and Revolution()

Hey guys,

I have a problem when I want to write a vtk with a 3D geometry which results from the revolution of a 2D spline.

For example, I took the torus example from “Netgen Examples” and added a vtk output in the attached script.
The resulting .vtk file then cannot be read by ParaView (it gives a strange error message).

Am I doing something wrong here?

Best, Philipp

Attachment: torus.py

Dear Philipp,

I cannot reprocude a problem with your file. Can you send your vtk-file to exclude that this is a paraview (version?) issue?
Also: Can you attach the “strange error messages”?


Dear Christoph,

I get the following error for both ParaView versions 5.5 and 5.6:

[code]Generic Warning: In /Users/kitware/dashboards/buildbot-slave/8275bd07/build/superbuild/paraview/src/VTK/IO/Legacy/vtkDataReader.cxx, line 1436
Error reading ascii data. Possible mismatch of datasize with declaration.

ERROR: In /Users/kitware/dashboards/buildbot-slave/8275bd07/build/superbuild/paraview/src/VTK/IO/Legacy/vtkUnstructuredGridReader.cxx, line 346
vtkUnstructuredGridReader (0x7fe194a11310): Unrecognized keyword: -0.899858

Attached you’ll find the vtk file (remove the .py etc. in the filename which I added to fool the restricted file extensions).
The NGSolve version which produced the file is 8ccd382e (09.02.19).

Best, Philipp

Attachment: geo-torus.vtk_2019-03-14.py

Your file works on my machine. So, I am still not sure if it’s a problem with the export or with paraview. My paraview version is 5.6.0.


Well, this is odd :wink:

My problem occurs on a Mac machine, however.
I just tried it on a Linux machine, and indeed, there does not seem to be a problem.

A quick google search reveals that this seems to happen occasionally on Mac systems:


Best, Philipp